A9 And PocketWizard Plus IIIe Transceiver

Colin

New Member
Original poster
Pro Member
Pro Member
Followers
0
Following
0
8
4
Aug 18, 2020
Country
United Kingdom
City/State
Suffolk
Has anyone used the Pocketwizzard plus IIIe with an A9 to remotely fire the camera ? I have tried but something is wrong, its not firing all the time. Some times it will fire the shutter once or twice. Other times it will fire every time for 30 Minutes or more and then just stop working. I have tried both on and of the hot shoe with the same results. My thoughts are it could be the cable at fault. Can anyone recommend a cable or anything else i can try please ? Colin.
 

Pro Membership Upgrade

  • If you'd like to support this community you can easily do so by becoming a Pro Member and unlocking the following benefits:

    ✓ No Adverts in the Forums
    ✓ Pro Member Competitions
    ✓ Sell Items in the Marketplace
    ✓ Unlimited Gallery Uploads
    ✓ Higher Resolution Gallery Uploads
    ✓ Forum Profile Signature
    ✓ Custom Profile Cover Photo
    ✓ Advertise Your Photography Workshops

    Pro Member Upgrade

Shopping Links

You can also support this site by purchasing gear through the following affiliate links:
Although I would recommend supporting your local camera store if you have one.

User Menu

alpha shooters text logo

© 2020 Alpha Shooters. All Rights Reserved.
Disclaimer: Alpha Shooters is an independently run website and is not affiliated with Sony.com
As an Amazon Associate I earn from qualifying purchases.