A9 HDMI problem

Welcome to the New Sony Alpha Shooters Community
Our community was only launched in August 2020 but is already thriving thanks to many amazing and helpful members. We'd love to welcome you on board too!
Join Now

Rachael Padman

Novice Member
Original poster
Pro Member
Pro Member
Followers
0
Following
1
30
16
Aug 18, 2020
Name
Rachael Padman
Country
United Kingdom
City/State
Suffolk
I have a strange problem with my A9, in that it does not output HDMI properly when in movie or S&Q mode. It does not matter what format -- same for HD and 4k.
If I turn on "Show Display Info" then _that_ does come through to the external monitor, but against a black background.

It seems to me that this must be a software issue: clearly all the circuitry for sending the sensor image to HDMI works, and equally, the mode dial to select Movie, S&Q etc works. I have had the camera for nearly two years, but never tried this before, so I am guessing the issue has been there all along.

My instinct is to reset to factory condition, and then redo all the updates, and customisation, but I thought I'd just test whether this is a known problem to which there is a simple fix. Any insight would be welcomed!
 
Solution2
But I forgot, you can't unwind the firmware updates, and can't reinstall them. So I am sending it off for repair.
Finally got it back today. All fixed. New PCB and new switch block. Interestingly, there are small differences in the firmware too -- no longer asks me if I want PAL when I turn it on. All credit to Sony, they have done a good job, they kept me informed, and they were good on the phone.

Rachael Padman

Novice Member
Original poster
Pro Member
Pro Member
Followers
0
Following
1
30
16
Aug 18, 2020
Name
Rachael Padman
Country
United Kingdom
City/State
Suffolk
Not sure if this is related to your issue, but maybe start here.

https://www.sony.com/electronics/support/articles/00120915
Thanks Mike. Yes, I had found those, but it's the other way round -- no HDMI output from the sensor in video modes, to anything, not even direct to a monitor. There is a nice YouTube video by Gerald Undone explaining most of the issues relating to the Sony article, which seem to be mostly about reducing the processing burden, but I know that other people do get HDMI video, so this must be one-off problem in my camera I think.
 

Rachael Padman

Novice Member
Original poster
Pro Member
Pro Member
Followers
0
Following
1
30
16
Aug 18, 2020
Name
Rachael Padman
Country
United Kingdom
City/State
Suffolk
My instinct is to reset to factory condition, and then redo all the updates, and customisation, but I thought I'd just test whether this is a known problem to which there is a simple fix. Any insight would be welcomed!
But I forgot, you can't unwind the firmware updates, and can't reinstall them. So I am sending it off for repair.
 

Rachael Padman

Novice Member
Original poster
Pro Member
Pro Member
Followers
0
Following
1
30
16
Aug 18, 2020
Name
Rachael Padman
Country
United Kingdom
City/State
Suffolk
But I forgot, you can't unwind the firmware updates, and can't reinstall them. So I am sending it off for repair.
Finally got it back today. All fixed. New PCB and new switch block. Interestingly, there are small differences in the firmware too -- no longer asks me if I want PAL when I turn it on. All credit to Sony, they have done a good job, they kept me informed, and they were good on the phone.
 
Solution

Pro Membership Upgrade

  • If you'd like to support this community you can easily do so by becoming a Pro Member and unlocking the following benefits:

    ✓ No Adverts in the Forums
    ✓ Pro Member Competitions
    ✓ Sell Items in the Marketplace
    ✓ Unlimited Gallery Uploads
    ✓ Higher Resolution Gallery Uploads
    ✓ Forum Profile Signature
    ✓ Custom Profile Cover Photo
    ✓ Advertise Your Photography Workshops

    Pro Member Upgrade

Shopping Links

You can also support this site by purchasing gear through the following affiliate links:
Although I would recommend supporting your local camera store if you have one.

User Menu

alpha shooters text logo

© 2020 Alpha Shooters. All Rights Reserved.
Disclaimer: Alpha Shooters is an independently run website and is not affiliated with Sony.com
As an Amazon Associate I earn from qualifying purchases.