Flash in Low-lite w shutter disabled issue.

garuda

Well-known member
Original poster
Pro Member
Pro Member
Followers
3
Following
0
141
66
Sep 14, 2020
Name
Mike
City/State
Illinois
Sony F43M onboard 7R iv. Flash manual states: in low lite when shutter button pushed halfway for AF, the flash's red "AF illuminator" lite to assist cam AF is triggered.

But with my half-shut-but disabled & moved to BB AF-ON, is cam smart enough to know to use the AF-ON button to trigger flash "AF illuminator" when pressed in low lite?
 

SteveK

Member
Pro Member
Pro Member
Followers
0
Following
2
24
62
Nov 5, 2020
Name
Steve Keltner
Country
United States
City/State
Kennewick
Sony F43M onboard 7R iv. Flash manual states: in low lite when shutter button pushed halfway for AF, the flash's red "AF illuminator" lite to assist cam AF is triggered.

But with my half-shut-but disabled & moved to BB AF-ON, is cam smart enough to know to use the AF-ON button to trigger flash "AF illuminator" when pressed in low lite?
Not sure about this, I don't think you can use BB as half press since it is all or nothing. SB is only button that you can actually half press. I put SB AF-on in "my menu" to turn on/off quickly for issues like this. I shoot OC Flash almost 100% of the time when using flash, so I have no experience with AF illuminator for the most part.
 

garuda

Well-known member
Original poster
Pro Member
Pro Member
Followers
3
Following
0
141
66
Sep 14, 2020
Name
Mike
City/State
Illinois
........ I don't think you can use BB as half press since it is all or nothing. SB is only button that you can actually half press.
Thanks for reply, but my wording may have confused the real issue. By default, half-press shut-butt activates AF. But w/o long reason, suffice that I moved AF to a BB (AF-ON). But to achieve this, half-press shut-but must be disabled in menu.

You're right, BBs can't half press. I use BB for focusing. But if flash likely hard-wired to trigger AF illuminator w half-shut-butt, then disabling shutter may negate this. My question is, with shutter permanently disabled and AF now xfer'd to BB -- will BB now serve to trigger illuminator, since shutter is disabled. I can't tell if lite is red when I try it.

Edit: Some might suggest, "Try it and see." I did but can't tell without comparison, and I'm not changing all menu setting back to old.
 
Last edited:

SteveK

Member
Pro Member
Pro Member
Followers
0
Following
2
24
62
Nov 5, 2020
Name
Steve Keltner
Country
United States
City/State
Kennewick
Thanks for reply, but my wording may have confused the real issue. By default, half-press shut-butt activates AF. But w/o long reason, suffice that I moved AF to a BB (AF-ON). But to achieve this, half-press shut-but must be disabled in menu.

You're right, BBs can't half press. I use BB for focusing. But if flash likely hard-wired to trigger AF illuminator w half-shut-butt, then disabling shutter may negate this. My question is, with shutter permanently disabled and AF now xfer'd to BB -- will BB now serve to trigger illuminator, since shutter is disabled. I can't tell if lite is red when I try it.

Edit: Some might suggest, "Try it and see." I did but can't tell without comparison, and I'm not changing all menu setting back to old.
I'd go into the menus and make sure AF Illuminator is on after you set BB focus and turn off SB. See if it is greyed out or won't let you change it, if the camera illuminator won't work, safe to say Flash won't work either. It may give you a message that the Flash will do it vs the camera. You can still back button even with SB active, but BB will over-ride anything you did with SB (focus) half press. I wonder if you can half press then BB and still get the half press function for various "half press" things. I know OSS will work if you half press with SB for focus off.

Anyways, try putting a piece of paper over the illuminator and shoot in front of a mirror, it should lite up through the paper if it is working. I don't have any Sony flashes or I'd give it a go.
 
Last edited:

garuda

Well-known member
Original poster
Pro Member
Pro Member
Followers
3
Following
0
141
66
Sep 14, 2020
Name
Mike
City/State
Illinois
.....Anyways, try putting a piece of paper over the illuminator and shoot in front of a mirror, it should lite up through the paper if it is working. I don't have any Sony flashes or I'd give it a go.
Thanks Steve, tried that but nothing. Image exposures are fine in cam's AUTO mode, but not in P, A, S, or Man. Bummer. Found nothing in flash manual. I'll experiment more. I'm just not keen in shooting entirely AUTO mode with flash.
 

Pro Membership Upgrade

  • If you'd like to support this community you can easily do so by becoming a Pro Member and unlocking the following benefits:

    ✓ No Adverts in the Forums
    ✓ Pro Member Competitions
    ✓ Sell Items in the Marketplace
    ✓ Unlimited Gallery Uploads
    ✓ Higher Resolution Gallery Uploads
    ✓ Forum Profile Signature
    ✓ Custom Profile Cover Photo
    ✓ Advertise Your Photography Workshops

    Pro Member Upgrade

Shopping Links

You can also support this site by purchasing gear through the following affiliate links:
Although I would recommend supporting your local camera store if you have one.

User Menu

alpha shooters text logo

© 2020 Alpha Shooters. All Rights Reserved.
Disclaimer: Alpha Shooters is an independently run website and is not affiliated with Sony.com
As an Amazon Associate I earn from qualifying purchases.