Sony HVL-F56AM

Welcome to the New Sony Alpha Shooters Community
Our community was only launched in August 2020 but is already thriving thanks to many amazing and helpful members. We'd love to welcome you on board too!
Join Now

iain clyne

Active Member
Original poster
Followers
0
Following
0
34
29
Apr 9, 2022
Name
Iain Clyne
I have bought a HVL-F56AM flash and a ADP-MAA needed for it to be used on my A9 but the flash will not turn on when mounted on the camera. It is fine when not mounted. Have I missed something?
 

iain clyne

Active Member
Original poster
Followers
0
Following
0
34
29
Apr 9, 2022
Name
Iain Clyne
Problem solved, I didn't have it on mechanical shutter.
 

Pro Membership Upgrade

  • If you'd like to support this community you can easily do so by becoming a Pro Member and unlocking the following benefits:

    ✓ No Adverts in the Forums
    ✓ Pro Member Competitions
    ✓ Sell Items in the Marketplace
    ✓ Unlimited Gallery Uploads
    ✓ Higher Resolution Gallery Uploads
    ✓ Forum Profile Signature
    ✓ Custom Profile Cover Photo
    ✓ Advertise Your Photography Workshops

    Pro Member Upgrade

Shopping Links

You can also support this site by purchasing gear through the following affiliate links:
Although I would recommend supporting your local camera store if you have one.

User Menu

alpha shooters text logo

© 2020 Alpha Shooters. All Rights Reserved.
Disclaimer: Alpha Shooters is an independently run website and is not affiliated with Sony.com
As an Amazon Associate I earn from qualifying purchases.