A7 III with metal flash bracket

Welcome to the New Sony Alpha Shooters Community
Our community was only launched in August 2020 but is already thriving thanks to many amazing and helpful members. We'd love to welcome you on board too!
Join Now

Stephonb

Newcomer
Original poster
Followers
0
Following
0
5
3
Sep 21, 2022
Name
Prince Stephon Brock
This is my setup. A7 III With a Godox ProX S trigger mounted on the hot shoe. A Godox V860 II flash attached to a Metal flash bracket cold shoe. Bracket attached to A7 III via the tripod mount on bottom of camera. Camera, Trigger and Flash all turned on. Trigger and flash on same channel and group. Problem - Flash will not operate as long as it it attached to the metal bracket or within 3" of the bracket. If I remove the flash and move it more than 3" from the cold shoe it works every time. If I attach the flash directly to the camera it works every time. Has anybody else experienced this? When I mount same set up on an old hard plastic grip everything works fine.
 

Sorefined

Well Known Member
Pro Member
Pro Member
Followers
1
Following
0
350
218
May 20, 2022
Name
Ray Richardson
Maybe you need to check the godox digital interface signal spread......it may be being so close to the hot shoe trigger , albeit on a cold shoe, your flash is effectively outside the operating zone.... whilst moving out further as you suggest, you are effectively bringing your flash into the signal catchment area which i believe is up to 100m......

I assume the flash is at 90 Deg to your trigger front facing direction.....
 

Stephonb

Newcomer
Original poster
Followers
0
Following
0
5
3
Sep 21, 2022
Name
Prince Stephon Brock
The flash is within 6 inches of the trigger at all times, Flash head orientation has no effect. Will not fire if attached to cold shoe or within 3 inches of cold shoe. Moving to 12 inches away and it fires every time.
 

Stephonb

Newcomer
Original poster
Followers
0
Following
0
5
3
Sep 21, 2022
Name
Prince Stephon Brock
The flash is within 6 inches of the trigger at all times, Flash head orientation has no effect. Will not fire if attached to cold shoe or within 3 inches of cold shoe. Moving to 12 inches away and it fires every time.
 

Attachments

  • D8F822DA-1DBD-4D13-A906-99DEFB6036BA.jpeg
    D8F822DA-1DBD-4D13-A906-99DEFB6036BA.jpeg
    401.3 KB · Views: 3
  • 47A4F84F-2CC7-4ED5-84FE-0DD587C94281.jpeg
    47A4F84F-2CC7-4ED5-84FE-0DD587C94281.jpeg
    181.1 KB · Views: 3
  • F595AD9A-DF4C-4F55-8CD4-DF61C6050084.jpeg
    F595AD9A-DF4C-4F55-8CD4-DF61C6050084.jpeg
    467 KB · Views: 3

Stephonb

Newcomer
Original poster
Followers
0
Following
0
5
3
Sep 21, 2022
Name
Prince Stephon Brock
Here are the photos. The flash head is at 90 degrees. I tested it again while taking these images. Flash mounted on bracket no flash. Moved flash off bracket 5 inches away and it fires every time.
 

Pro Membership Upgrade

  • If you'd like to support this community you can easily do so by becoming a Pro Member and unlocking the following benefits:

    ✓ No Adverts in the Forums
    ✓ Pro Member Competitions
    ✓ Sell Items in the Marketplace
    ✓ Unlimited Gallery Uploads
    ✓ Higher Resolution Gallery Uploads
    ✓ Forum Profile Signature
    ✓ Custom Profile Cover Photo
    ✓ Advertise Your Photography Workshops

    Pro Member Upgrade

Shopping Links

You can also support this site by purchasing gear through the following affiliate links:
Although I would recommend supporting your local camera store if you have one.

User Menu

alpha shooters text logo

© 2020 Alpha Shooters. All Rights Reserved.
Disclaimer: Alpha Shooters is an independently run website and is not affiliated with Sony.com
As an Amazon Associate I earn from qualifying purchases.